Delayed cluster modifications in Azure East US 2

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 20:23 UTC

Monitoring

We're seeing capacity errors come down in Azure Eastus2. We will continue monitoring the situation.
Posted Sep 10, 2025 - 20:06 UTC

Update

Azure Eastus2 continues to experience elevated errors. Azure has now published it on their public status page here https://azure.status.microsoft/en-us/status
Posted Sep 10, 2025 - 17:50 UTC

Identified

We are observing elevated error when provisioning resources due to an Azure service issue. Customers may see delayed cluster modifications for Azure clusters in East US 2. Please refer to the Azure dashboard for their service issue updates.
Posted Sep 10, 2025 - 12:34 UTC
This incident affected: MongoDB Cloud.