Support Portal Outage

Incident Report for MongoDB Cloud

Resolved

The MongoDB Support Portal experienced service degradation issues between approximately 2026-09-16 09:00 UTC and 2026-09-16 15:15 UTC. These platform issues have been resolved.

We apologize for the service interruption and greatly appreciate your patience.

Regards,
The MongoDB Team
Posted Sep 16, 2026 - 15:31 UTC

Update

We are continuing to investigate this issue.
Posted Sep 16, 2026 - 09:09 UTC

Investigating

MongoDB customers are currently experiencing degraded or limited access to the MongoDB Customer Support Portal (https://support.mongodb.com/).

If you require assistance with a critical MongoDB Technical Support issue and are unable to access the Customer Support Portal, please contact us using one of the numbers listed below:

[These numbers have been removed. Active MongoDB customers can access them at the support portal.]

We appreciate your patience.
Posted Sep 16, 2026 - 09:06 UTC
This incident affected: MongoDB Support Portal.