Atlas User Interface is Unavailable

Incident Report for MongoDB Cloud

Resolved

We have increased capacity for the Atlas User Interface and have been monitoring for the past hour. At this stage, we are stable and have recovered. We are continuing to investigate root cause to ensure this specific failure doesn’t happen again.
Posted Jul 15, 2025 - 13:35 UTC

Update

We are continuing to monitor for any further issues. Cluster health remains unaffected.
Posted Jul 15, 2025 - 12:32 UTC

Monitoring

Access to the Atlas User Interface has been restored, and we are monitoring closely.
Posted Jul 15, 2025 - 11:43 UTC

Investigating

The Atlas User Interface. is currently unavailable, and we are working to restore access. All clusters remain accessible and API operations are not impacted.
Posted Jul 15, 2025 - 11:32 UTC
This incident affected: MongoDB Cloud.