Action Needed for Vercel Marketplace Integration Users

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 00:30 UTC

Monitoring

This status alert only applies to customers who deployed MongoDB Atlas via the Vercel Marketplace.

We are asking customers to promptly redeploy their Vercel applications.

As part of our response to the React’s CVE-2025-55182 (https://vercel.com/changelog/cve-2025-55182) the critical security advisory affecting React Server Components, some MongoDB customers will need to take action.

Specifically, MongoDB Atlas customers who deployed clusters via the Vercel Marketplace will need to ensure their applications are running on an unaffected version of Next.js (instructions here: https://vercel.com/kb/bulletin/react2shell) and redeploy their Vercel applications (instructions here: https://vercel.com/docs/deployments/managing-deployments). This is to avoid a loss of database connectivity from your Vercel deployment.

All other Atlas functionality is unaffected. Users who have not deployed MongoDB Atlas via the Vercel Marketplace are not affected.
Posted Dec 10, 2025 - 01:51 UTC
This incident affected: MongoDB Cloud.