Atlas Azure cluster new snapshot creation failure (australiaeast)

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 21:13 UTC

Monitoring

We've identified the root cause which is an Azure outage: https://azure.status.microsoft/en-us/status. Will continue to monitor.
Posted Nov 03, 2025 - 20:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 03, 2025 - 19:27 UTC

Investigating

We're investigating an issue impacting Atlas Azure cluster snapshot creation (australiaeast region only). This only affects new snapshot creation. Existing snapshots are not affected.
Posted Nov 03, 2025 - 19:00 UTC
This incident affected: MongoDB Cloud.