Delayed Cluster Management Operations

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 02:38 UTC

Monitoring

The fix has been deployed and Atlas cluster management operations are no longer delayed.
Posted Oct 29, 2025 - 02:34 UTC

Identified

We have identified an issue that is causing delays in Atlas cluster management operations. Cluster health is unaffected. A fix has been deployed and we expect improvement shortly.
Posted Oct 29, 2025 - 02:30 UTC
This incident affected: MongoDB Cloud.