MongoDB Cloud: Login error "Too many attempts, please try again later"
Incident Report for MongoDB Cloud
Postmortem

Incident Summary

On September 2, 2024 between 8:30 UTC to 10:15 UTC, some MongoDB customers were unable to log in to MongoDB Atlas Management UI.

During that time, MongoDB experienced an abnormally high volume of traffic on our login page that caused us to hit our rate limiting thresholds which caused some customers to see their authentication requests to the MongoDB Atlas Management UI rejected.

Once login volume subsided, login availability was restored.

Note: This incident had no impact on customer Atlas Clusters. UI authentication is independent of Atlas Cluster authentication.

Root Cause

Our authentication services were not able to scale quickly enough to react to the sudden increase in logins.

MongoDB Actions

We are updating our login page to provide clearer and more actionable error messaging. We are also adding additional support to  scale better during traffic spikes.

Recommended Customer Actions

No further customer action required

Posted Sep 12, 2024 - 14:37 UTC

Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 14:28 UTC
Monitoring
The system has recovered, users should be able to login.

We are continuing to monitor the system for any residual effects.
Posted Sep 02, 2024 - 11:08 UTC
Investigating
We have received higher-than-normal reports of failed logins for cloud.mongodb.com with the reason "Too many attempts, please try again later"
Posted Sep 02, 2024 - 10:13 UTC
This incident affected: MongoDB Cloud.