Activity Feed is experiencing degraded performance

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 23:55 UTC

Monitoring

We have deployed a fix and are seeing activity feed pages load again.
Posted Jan 29, 2026 - 23:54 UTC

Update

The revert of the recent change did not meaningfully help the situation. However, we have looked into the issue more and have a better idea of the root cause. We will have another update shortly.
Posted Jan 29, 2026 - 23:34 UTC

Update

We are reverting a recent change in one of the impacted services. We will have an update after that rolls out.
Posted Jan 29, 2026 - 23:24 UTC

Investigating

We are currently investigating an issue with the activity feed. We will update as the we learn more.
Posted Jan 29, 2026 - 22:30 UTC
This incident affected: MongoDB Cloud.