Atlas Backup Export Jobs Degraded Performance

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted May 07, 2026 - 20:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2026 - 20:02 UTC

Update

We are continuing to work on the fix for this issue. We will have another update by May 7 16:00 UTC.
Posted May 07, 2026 - 01:20 UTC

Identified

Identified - We have identified an issue causing failures for a subset of Atlas backup export jobs. We are actively working on a fix. Your cluster health and data are unaffected. We will provide another update by May 7 01:30 UTC
Posted May 06, 2026 - 21:48 UTC
This incident affected: MongoDB Cloud and MongoDB Atlas for Government.